# CVE-2021-21267: Regular Expression Denial-of-Service in npm schema-inspector

> An attacker can cause a denial of service by providing a specially crafted email address to the schema-inspector library, freezing the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-f38p-c2gq-4pmr

## What is CVE-2021-21267?

CVE-2021-21267 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Schema-Inspector is an open-source tool to sanitize and validate JS objects (npm package schema-inspector). In before version 2.0.0, email address validation is vulnerable to a denial-of-service attack where some input (for example `a@0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.`) will freeze the program or web browser page executing the code. This affects any current schema-inspector users using any version to validate email addresses. Users who do not do email validation, and instead do other types of validation (like string min or max length, etc), are not affected. Users should upgrade to version 2.0.0, which uses a regex expression that isn't vulnerable to ReDoS.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-21267?

2 open source packages ship an affected version, including schema-inspector. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `schema-inspector` | npm | All versions | 2.0.0 |
| `schema-inspector` | npm | All versions | 2.0.0 |

Products: Netapp E-Series Performance Analyzer, Netapp Oncommand Insight, Schema-Inspector Project Schema-Inspector.

## How do I fix CVE-2021-21267?

Upgrade schema-inspector to 2.0.0 or later.

## Is CVE-2021-21267 being exploited?

There is no known exploitation of CVE-2021-21267 in the wild and no public exploit code.

## Other vulnerabilities in Netapp E-Series Performance Analyzer

- [CVE-2021-32640](https://insights.sbomify.com/CVE-2021-32640/): ReDoS in Sec-Websocket-Protocol header (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21267 and fix it if it is affected.

What it is: CVE-2021-21267 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21267 in the wild and no public exploit code.

Affected packages and fixed versions:
- schema-inspector (npm): affected all versions; fixed in 2.0.0
- schema-inspector (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21267/ (Markdown: https://insights.sbomify.com/CVE-2021-21267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21267
- OSV: https://osv.dev/vulnerability/CVE-2021-21267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21267/
Summaries are generated and may contain mistakes; the official description above is the record.
