# CVE-2021-21274: Denial of service attack via .well-known lookups

> A malicious homeserver can cause resource exhaustion in Synapse by redirecting .well-known requests to large files, leading to denial of service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2hwx-mjrm-v3g8, PYSEC-2021-132, UBUNTU-CVE-2021-21274

## What is CVE-2021-21274?

CVE-2021-21274 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.25.0, a malicious homeserver could redirect requests to their .well-known file to a large file. This can lead to a denial of service attack where homeservers will consume significantly more resources when requesting the .well-known file of a malicious homeserver. This affects any server which accepts federation requests from untrusted servers. Issue is resolved in version 1.25.0. As a workaround the `federation_domain_whitelist` setting can be used to restrict the homeservers communicated with over federation.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21274?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | From 0.99.0 | 1.25.0 |
| `matrix-synapse` | PyPI | From 0.99.0 | 1.25.0 |
| `matrix-synapse` | PyPI | From 0.99.0 | 1.25.0 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-21274?

Upgrade matrix-synapse to 1.25.0 or later.

## Is CVE-2021-21274 being exploited?

There is no known exploitation of CVE-2021-21274 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21274 and fix it if it is affected.

What it is: CVE-2021-21274 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21274 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected from 0.99.0; fixed in 1.25.0
- matrix-synapse (PyPI): affected from 0.99.0; fixed in 1.25.0
- matrix-synapse (PyPI): affected from 0.99.0; fixed in 1.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21274/ (Markdown: https://insights.sbomify.com/CVE-2021-21274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21274
- OSV: https://osv.dev/vulnerability/CVE-2021-21274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21274/
Summaries are generated and may contain mistakes; the official description above is the record.
