{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21276 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-21276 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-21276 is a critical vulnerability in cydrobolt polr, published on 1 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21276 and fix it if it is affected.\n\nWhat it is: CVE-2021-21276 is a critical vulnerability in cydrobolt polr, published on 1 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21276 in the wild and no public exploit code.\n\nAffected product: cydrobolt polr. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21276/ (Markdown: https://insights.sbomify.com/CVE-2021-21276/index.md)","id":"CVE-2021-21276","markdown":"https://insights.sbomify.com/CVE-2021-21276/index.md","name":"CVE-2021-21276","record":{"aliases":["GHSA-vg6w-8w9v-xxqc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"URL shortener","requires_auth":"none","summary":"Attackers can gain admin access to Polr instances by crafting specific cookie headers to the setup endpoint, bypassing authentication checks.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"polr","vendor":"polrproject"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Polr is an open source URL shortener. in Polr before version 2.3.0, a vulnerability in the setup process allows attackers to gain admin access to site instances, even if they do not possess an existing account. This vulnerability exists regardless of users' settings. If an attacker crafts a request with specific cookie headers to the /setup/finish endpoint, they may be able to obtain admin privileges on the instance. This is caused by a loose comparison (==) in SetupController that is susceptible to attack. The project has been patched to ensure that a strict comparison (===) is used to verify the setup key, and that /setup/finish verifies that no users table exists before performing any migrations or provisioning any new accounts. This is fixed in version 2.3.0. Users can patch this vulnerability without upgrading by adding abort(404) to the very first line of finishSetup in SetupController.php.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2023-04-06","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-04-06","kind":"exploitdb","ref":"51277","stars":null,"title":"POLR URL 2.3.0 - Shortener Admin Takeover"}],"tier":"poc_unverified"},"has_fix":false,"headline":"Privilege escalation in Polr","id":"CVE-2021-21276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Angular Expressions - Remote Code Execution","id":"CVE-2021-21277"},"packages":[],"prev":{"headline":"CSRF in MediaWiki Report extension","id":"CVE-2021-21275"},"products":["polr"],"published":"2021-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["cydrobolt"]},"summary":"Attackers can gain admin access to Polr instances by crafting specific cookie headers to the setup endpoint, bypassing authentication checks.","url":"https://insights.sbomify.com/CVE-2021-21276/"}