# CVE-2021-21276: Privilege escalation in Polr

> Attackers can gain admin access to Polr instances by crafting specific cookie headers to the setup endpoint, bypassing authentication checks.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vg6w-8w9v-xxqc

## What is CVE-2021-21276?

CVE-2021-21276 is a critical vulnerability in cydrobolt polr, published on 1 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Polr is an open source URL shortener. in Polr before version 2.3.0, a vulnerability in the setup process allows attackers to gain admin access to site instances, even if they do not possess an existing account. This vulnerability exists regardless of users' settings. If an attacker crafts a request with specific cookie headers to the /setup/finish endpoint, they may be able to obtain admin privileges on the instance. This is caused by a loose comparison (==) in SetupController that is susceptible to attack. The project has been patched to ensure that a strict comparison (===) is used to verify the setup key, and that /setup/finish verifies that no users table exists before performing any migrations or provisioning any new accounts. This is fixed in version 2.3.0. Users can patch this vulnerability without upgrading by adding abort(404) to the very first line of finishSetup in SetupController.php.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-21276?

It affects 1 product.


Products: Polrproject Polr.

## How do I fix CVE-2021-21276?

No fix has been published for CVE-2021-21276 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21276 being exploited?

There is no known exploitation of CVE-2021-21276 in the wild and no public exploit code.

Public exploit code:

- POLR URL 2.3.0 - Shortener Admin Takeover (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21276 and fix it if it is affected.

What it is: CVE-2021-21276 is a critical vulnerability in cydrobolt polr, published on 1 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21276 in the wild and no public exploit code.

Affected product: cydrobolt polr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21276/ (Markdown: https://insights.sbomify.com/CVE-2021-21276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21276
- OSV: https://osv.dev/vulnerability/CVE-2021-21276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21276/
Summaries are generated and may contain mistakes; the official description above is the record.
