{"answers":{"affected":"2 open source packages ship an affected version, including angular-expressions. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21277 in the wild and no public exploit code.","fix":"Upgrade angular-expressions to 1.1.2 or later.","what":"CVE-2021-21277 is a high-severity code injection vulnerability in peerigon angular-expressions, published on 1 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21277 and fix it if it is affected.\n\nWhat it is: CVE-2021-21277 is a high-severity code injection vulnerability in peerigon angular-expressions, published on 1 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular-expressions (npm): affected all versions; fixed in 1.1.2\n- angular-expressions (npm): affected all versions; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21277/ (Markdown: https://insights.sbomify.com/CVE-2021-21277/index.md)","id":"CVE-2021-21277","markdown":"https://insights.sbomify.com/CVE-2021-21277/index.md","name":"CVE-2021-21277","record":{"aliases":["GHSA-j6px-jwvv-vpwq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript expression library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code by injecting malicious payloads into user-controlled input processed by the angular-expressions library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"angular-expressions","vendor":"peerigon"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"angular-expressions is \"angular's nicest part extracted as a standalone module for the browser and node\". In angular-expressions before version 1.1.2 there is a vulnerability which allows Remote Code Execution if you call \"expressions.compile(userControlledInput)\" where \"userControlledInput\" is text that comes from user input. The security of the package could be bypassed by using a more complex payload, using a \".constructor.constructor\" technique. In terms of impact: If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. This is fixed in version 1.1.2 of angular-expressions A temporary workaround might be either to disable user-controlled input that will be fed into angular-expressions in your application or allow only following characters in the userControlledInput.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Angular Expressions - Remote Code Execution","id":"CVE-2021-21277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Risk of code injection in RSSHub","id":"CVE-2021-21278"},"packages":[{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":null,"source":"GHSA-j6px-jwvv-vpwq"},{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":"pkg:npm/angular-expressions","source":"GHSA-j6px-jwvv-vpwq"}],"prev":{"headline":"Privilege escalation in Polr","id":"CVE-2021-21276"},"products":["angular-expressions"],"published":"2021-02-01","related":[{"cvss_score":9.3,"headline":"Angular Expressions - Remote Code Execution using filters","id":"CVE-2026-44643","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.7,"headline":"Remote Code Execution in Angular Expressions","id":"CVE-2020-5219","kev_date_added":null,"published":"2020-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["peerigon"]},"summary":"Attackers can execute arbitrary code by injecting malicious payloads into user-controlled input processed by the angular-expressions library.","url":"https://insights.sbomify.com/CVE-2021-21277/"}