# CVE-2021-21277: Angular Expressions - Remote Code Execution

> Attackers can execute arbitrary code by injecting malicious payloads into user-controlled input processed by the angular-expressions library.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-j6px-jwvv-vpwq

## What is CVE-2021-21277?

CVE-2021-21277 is a high-severity code injection vulnerability in peerigon angular-expressions, published on 1 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

angular-expressions is "angular's nicest part extracted as a standalone module for the browser and node". In angular-expressions before version 1.1.2 there is a vulnerability which allows Remote Code Execution if you call "expressions.compile(userControlledInput)" where "userControlledInput" is text that comes from user input. The security of the package could be bypassed by using a more complex payload, using a ".constructor.constructor" technique. In terms of impact: If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. This is fixed in version 1.1.2 of angular-expressions A temporary workaround might be either to disable user-controlled input that will be fed into angular-expressions in your application or allow only following characters in the userControlledInput.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-21277?

2 open source packages ship an affected version, including angular-expressions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-expressions` | npm | All versions | 1.1.2 |
| `angular-expressions` | npm | All versions | 1.1.2 |

Products: Peerigon Angular-Expressions.

## How do I fix CVE-2021-21277?

Upgrade angular-expressions to 1.1.2 or later.

## Is CVE-2021-21277 being exploited?

There is no known exploitation of CVE-2021-21277 in the wild and no public exploit code.

## Other vulnerabilities in peerigon angular-expressions

- [CVE-2026-44643](https://insights.sbomify.com/CVE-2026-44643/): Angular Expressions - Remote Code Execution using filters (critical 9.3)
- [CVE-2020-5219](https://insights.sbomify.com/CVE-2020-5219/): Remote Code Execution in Angular Expressions (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21277 and fix it if it is affected.

What it is: CVE-2021-21277 is a high-severity code injection vulnerability in peerigon angular-expressions, published on 1 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21277 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-expressions (npm): affected all versions; fixed in 1.1.2
- angular-expressions (npm): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21277/ (Markdown: https://insights.sbomify.com/CVE-2021-21277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21277
- OSV: https://osv.dev/vulnerability/CVE-2021-21277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21277/
Summaries are generated and may contain mistakes; the official description above is the record.
