# CVE-2021-21282: Buffer overflow in RPL source routing header processing

> A buffer overflow in Contiki-NG's RPL source routing allows attackers to execute code or cause denial of service via crafted packets.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jun 2021
- **Updated:** 3 Aug 2024

## What is CVE-2021-21282?

CVE-2021-21282 is a high-severity memory corruption vulnerability in contiki-ng, published on 18 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contiki-NG is an open-source, cross-platform operating system for internet of things devices. In versions prior to 4.5, buffer overflow can be triggered by an input packet when using either of Contiki-NG's two RPL implementations in source-routing mode. The problem has been patched in Contiki-NG 4.5. Users can apply the patch for this vulnerability out-of-band as a workaround.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2021-21282?

It affects 1 product.


Products: Contiki-Ng Contiki-Ng.

## How do I fix CVE-2021-21282?

No fix has been published for CVE-2021-21282 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21282 being exploited?

There is no known exploitation of CVE-2021-21282 in the wild and no public exploit code.

## Other vulnerabilities in contiki-ng

- [CVE-2018-19417](https://insights.sbomify.com/CVE-2018-19417/): Memory corruption in n/a (critical 10.0)
- [CVE-2023-30546](https://insights.sbomify.com/CVE-2023-30546/): Contiki-NG has off-by-one error in Antelope DBMS (critical 9.8)
- [CVE-2020-24336](https://insights.sbomify.com/CVE-2020-24336/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-14934](https://insights.sbomify.com/CVE-2020-14934/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-14935](https://insights.sbomify.com/CVE-2020-14935/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21282 and fix it if it is affected.

What it is: CVE-2021-21282 is a high-severity memory corruption vulnerability in contiki-ng, published on 18 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21282 in the wild and no public exploit code.

Affected product: contiki-ng. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21282/ (Markdown: https://insights.sbomify.com/CVE-2021-21282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21282
- OSV: https://osv.dev/vulnerability/CVE-2021-21282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21282/
Summaries are generated and may contain mistakes; the official description above is the record.
