CVE-2021-21284 privilege escalation in Moby
Attackers with remapped root access can escalate to real root by modifying Docker files when userns-remap is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21284?
CVE-2021-21284 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
In Docker before versions 9.03.15, 20.10.3 there is a vulnerability involving the --userns-remap option in which access to remapped root allows privilege escalation to real root. When using "--userns-remap", if the root user in the remapped namespace has access to the host filesystem they can modify files under "/var/lib/docker/<remapping>" that cause writing files with extended privileges. Versions 20.10.3 and 19.03.15 contain patches that prevent privilege escalation from remapped user.
Weakness: CWE-22
Which versions are affected by CVE-2021-21284?
4 open source packages ship an affected version, including github.com/moby/moby. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/moby/moby Go | All versions | 19.3.15 |
github.com/moby/moby Go | All versions | 19.3.15 |
github.com/moby/moby Go | From 20.10.0-beta1 | 20.10.3 |
github.com/moby/moby Go | From 20.10.0-beta1 | 20.10.3 |
Products include Debian Debian Linux, Docker Docker, Netapp E-Series Santricity Os Controller.
How do I fix CVE-2021-21284?
Upgrade github.com/moby/moby to a fixed version for your release line: 19.3.15 or 20.10.3.
Is CVE-2021-21284 being exploited?
There is no known exploitation of CVE-2021-21284 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-QN82133, DEBIAN-CVE-2021-21284, GHSA-7452-xqpj-6rpc, UBUNTU-CVE-2021-21284.