# CVE-2021-21284: privilege escalation in Moby

> Attackers with remapped root access can escalate to real root by modifying Docker files when userns-remap is enabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLEANSTART-2026-QN82133, DEBIAN-CVE-2021-21284, GHSA-7452-xqpj-6rpc, UBUNTU-CVE-2021-21284

## What is CVE-2021-21284?

CVE-2021-21284 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Docker before versions 9.03.15, 20.10.3 there is a vulnerability involving the --userns-remap option in which access to remapped root allows privilege escalation to real root. When using "--userns-remap", if the root user in the remapped namespace has access to the host filesystem they can modify files under "/var/lib/docker/<remapping>" that cause writing files with extended privileges. Versions 20.10.3 and 19.03.15 contain patches that prevent privilege escalation from remapped user.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-21284?

4 open source packages ship an affected version, including github.com/moby/moby. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/moby/moby` | Go | All versions | 19.3.15 |
| `github.com/moby/moby` | Go | All versions | 19.3.15 |
| `github.com/moby/moby` | Go | From 20.10.0-beta1 | 20.10.3 |
| `github.com/moby/moby` | Go | From 20.10.0-beta1 | 20.10.3 |

Products: Debian Debian Linux, Docker Docker, Netapp E-Series Santricity Os Controller.

## How do I fix CVE-2021-21284?

Upgrade github.com/moby/moby to a fixed version for your release line: 19.3.15 or 20.10.3.

## Is CVE-2021-21284 being exploited?

There is no known exploitation of CVE-2021-21284 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21284 and fix it if it is affected.

What it is: CVE-2021-21284 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21284 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/moby/moby (Go): affected all versions; fixed in 19.3.15
- github.com/moby/moby (Go): affected all versions; fixed in 19.3.15
- github.com/moby/moby (Go): affected from 20.10.0-beta1; fixed in 20.10.3
- github.com/moby/moby (Go): affected from 20.10.0-beta1; fixed in 20.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21284/ (Markdown: https://insights.sbomify.com/CVE-2021-21284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21284
- OSV: https://osv.dev/vulnerability/CVE-2021-21284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21284/
Summaries are generated and may contain mistakes; the official description above is the record.
