CVE-2021-21285 Docker daemon crash during image pull of malicious image
An attacker can crash the Docker daemon by pulling a maliciously crafted image manifest, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21285?
CVE-2021-21285 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Docker before versions 9.03.15, 20.10.3 there is a vulnerability in which pulling an intentionally malformed Docker image manifest crashes the dockerd daemon. Versions 20.10.3 and 19.03.15 contain patches that prevent the daemon from crashing.
Which versions are affected by CVE-2021-21285?
4 open source packages ship an affected version, including github.com/moby/moby. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/moby/moby Go | All versions | 19.3.15 |
github.com/moby/moby Go | All versions | 19.3.15 |
github.com/moby/moby Go | From 20.10.0-beta1 | 20.10.3 |
github.com/moby/moby Go | From 20.10.0-beta1 | 20.10.3 |
Products include Debian Debian Linux, Docker Docker, Netapp E-Series Santricity Os Controller.
How do I fix CVE-2021-21285?
Upgrade github.com/moby/moby to a fixed version for your release line: 19.3.15 or 20.10.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-21285 being exploited?
There is no known exploitation of CVE-2021-21285 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-TE15990, DEBIAN-CVE-2021-21285, GHSA-6fj5-m822-rqx8, UBUNTU-CVE-2021-21285.