# CVE-2021-21285: Docker daemon crash during image pull of malicious image

> An attacker can crash the Docker daemon by pulling a maliciously crafted image manifest, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLEANSTART-2026-TE15990, DEBIAN-CVE-2021-21285, GHSA-6fj5-m822-rqx8, UBUNTU-CVE-2021-21285

## What is CVE-2021-21285?

CVE-2021-21285 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Docker before versions 9.03.15, 20.10.3 there is a vulnerability in which pulling an intentionally malformed Docker image manifest crashes the dockerd daemon. Versions 20.10.3 and 19.03.15 contain patches that prevent the daemon from crashing.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21285?

4 open source packages ship an affected version, including github.com/moby/moby. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/moby/moby` | Go | All versions | 19.3.15 |
| `github.com/moby/moby` | Go | All versions | 19.3.15 |
| `github.com/moby/moby` | Go | From 20.10.0-beta1 | 20.10.3 |
| `github.com/moby/moby` | Go | From 20.10.0-beta1 | 20.10.3 |

Products: Debian Debian Linux, Docker Docker, Netapp E-Series Santricity Os Controller.

## How do I fix CVE-2021-21285?

Upgrade github.com/moby/moby to a fixed version for your release line: 19.3.15 or 20.10.3.

## Is CVE-2021-21285 being exploited?

There is no known exploitation of CVE-2021-21285 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21285 and fix it if it is affected.

What it is: CVE-2021-21285 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21285 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/moby/moby (Go): affected all versions; fixed in 19.3.15
- github.com/moby/moby (Go): affected all versions; fixed in 19.3.15
- github.com/moby/moby (Go): affected from 20.10.0-beta1; fixed in 20.10.3
- github.com/moby/moby (Go): affected from 20.10.0-beta1; fixed in 20.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21285/ (Markdown: https://insights.sbomify.com/CVE-2021-21285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21285
- OSV: https://osv.dev/vulnerability/CVE-2021-21285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21285/
Summaries are generated and may contain mistakes; the official description above is the record.
