{"answers":{"affected":"2 open source packages ship an affected version, including mechanize. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-21289 in the wild and no public exploit code.","fix":"Upgrade mechanize to 2.7.7 or later.","what":"CVE-2021-21289 is a high-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021."},"fix_prompt":"Check this codebase for CVE-2021-21289 and fix it if it is affected.\n\nWhat it is: CVE-2021-21289 is a high-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. \nExploitation: There is no known exploitation of CVE-2021-21289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mechanize (RubyGems): affected from 2.0.0; fixed in 2.7.7\n- mechanize (RubyGems): affected from 2.0.0; fixed in 2.7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21289/ (Markdown: https://insights.sbomify.com/CVE-2021-21289/index.md)","id":"CVE-2021-21289","markdown":"https://insights.sbomify.com/CVE-2021-21289/index.md","name":"CVE-2021-21289","record":{"aliases":["DEBIAN-CVE-2021-21289","DLA-2561-1","GHSA-qrqm-fpv6-6r8g","MGASA-2021-0124","UBUNTU-CVE-2021-21289"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"mechanize","vendor":"mechanize_project"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Mechanize is an open-source ruby library that makes automated web interaction easy. In Mechanize from version 2.0.0 and before version 2.7.7 there is a command injection vulnerability. Affected versions of mechanize allow for OS commands to be injected using several classes' methods which implicitly use Ruby's Kernel.open method. Exploitation is possible only if untrusted input is used as a local filename and passed to any of these calls: Mechanize::CookieJar#load, Mechanize::CookieJar#save_as, Mechanize#download, Mechanize::Download#save, Mechanize::File#save, and Mechanize::FileResponse#read_body. This is fixed in version 2.7.7.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection Vulnerability in Mechanize","id":"CVE-2021-21289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":null,"year":"2021"},"n_packages":2,"n_references":8,"next":{"headline":"Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files","id":"CVE-2021-21290"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.7"],"introduced":["2.0.0"],"last_affected":[],"package":"mechanize","purl":null,"source":"GHSA-qrqm-fpv6-6r8g"},{"ecosystem":"RubyGems","fixed":["2.7.7"],"introduced":["2.0.0"],"last_affected":[],"package":"mechanize","purl":"pkg:gem/mechanize","source":"GHSA-qrqm-fpv6-6r8g"}],"prev":{"headline":"Server-side request forgery in CarrierWave","id":"CVE-2021-21288"},"products":["mechanize"],"published":"2021-02-02","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["sparklemotion"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-21289/"}