# CVE-2021-21289: Command Injection Vulnerability in Mechanize


- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-21289, DLA-2561-1, GHSA-qrqm-fpv6-6r8g, MGASA-2021-0124, UBUNTU-CVE-2021-21289

## What is CVE-2021-21289?

CVE-2021-21289 is a high-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. 

### Official description

Mechanize is an open-source ruby library that makes automated web interaction easy. In Mechanize from version 2.0.0 and before version 2.7.7 there is a command injection vulnerability. Affected versions of mechanize allow for OS commands to be injected using several classes' methods which implicitly use Ruby's Kernel.open method. Exploitation is possible only if untrusted input is used as a local filename and passed to any of these calls: Mechanize::CookieJar#load, Mechanize::CookieJar#save_as, Mechanize#download, Mechanize::Download#save, Mechanize::File#save, and Mechanize::FileResponse#read_body. This is fixed in version 2.7.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-21289?

2 open source packages ship an affected version, including mechanize. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mechanize` | RubyGems | From 2.0.0 | 2.7.7 |
| `mechanize` | RubyGems | From 2.0.0 | 2.7.7 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mechanize Project Mechanize.

## How do I fix CVE-2021-21289?

Upgrade mechanize to 2.7.7 or later.

## Is CVE-2021-21289 being exploited?

There is no known exploitation of CVE-2021-21289 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21289 and fix it if it is affected.

What it is: CVE-2021-21289 is a high-severity vulnerability in Debian Debian Linux, published on 2 Feb 2021. 
Exploitation: There is no known exploitation of CVE-2021-21289 in the wild and no public exploit code.

Affected packages and fixed versions:
- mechanize (RubyGems): affected from 2.0.0; fixed in 2.7.7
- mechanize (RubyGems): affected from 2.0.0; fixed in 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21289/ (Markdown: https://insights.sbomify.com/CVE-2021-21289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21289
- OSV: https://osv.dev/vulnerability/CVE-2021-21289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21289/
Summaries are generated and may contain mistakes; the official description above is the record.
