CVE-2021-21290 Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files
Local attackers can read sensitive temporary files created by Netty's multipart decoders on Unix-like systems if disk storage is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21290?
CVE-2021-21290 is a medium-severity vulnerability in Debian Debian Linux, published on 8 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to information disclosure. Of note, this does not impact modern MacOS Operating Systems. The method "File.createTempFile" on unix-like systems creates a random file, but, by default will create this file with the permissions "-rw-r--r--". Thus, if sensitive information is written to this file, other local users can read this information. This is the case in netty's "AbstractDiskHttpData" is vulnerable. This has been fixed in version 4.1.59.Final. As a workaround, one may specify your own "java.io.tmpdir" when you start the JVM or use "DefaultHttpDataFactory.setBaseDir(...)" to set the directory to something that is only readable by the current user.
Which versions are affected by CVE-2021-21290?
6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-codec-http and org.jboss.netty:netty. It affects 13 products.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty Maven | All versions | None |
io.netty:netty Maven | All versions | None |
io.netty:netty-codec-http Maven | From 4.0.0 | 4.1.59.Final |
io.netty:netty-codec-http Maven | From 4.0.0 | 4.1.59.Final |
org.jboss.netty:netty Maven | All versions | None |
org.jboss.netty:netty Maven | All versions | None |
Linux distribution packages (6)
satellite Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
satellite-cli Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
satellite-common Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
satellite Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
satellite-capsule Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
satellite-common Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
Products include Debian Debian Linux, Netapp Active Iq Unified Manager, Netapp Cloud Secure Agent, Netapp Snapcenter, Netty Netty, Oracle Banking Corporate Lending Process Management and 7 more.
How do I fix CVE-2021-21290?
Upgrade to a fixed version.
Is CVE-2021-21290 being exploited?
There is no known exploitation of CVE-2021-21290 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-LZ91805, DEBIAN-CVE-2021-21290, DLA-2555-1, GHSA-5mcr-gq6c-3hq2, MGASA-2021-0136, OESA-2021-1143 and 2 more.