# CVE-2021-21290: Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files

> Local attackers can read sensitive temporary files created by Netty's multipart decoders on Unix-like systems if disk storage is enabled.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2021
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-LZ91805, DEBIAN-CVE-2021-21290, DLA-2555-1, GHSA-5mcr-gq6c-3hq2, MGASA-2021-0136, OESA-2021-1143, RHSA-2022:0190, UBUNTU-CVE-2021-21290

## What is CVE-2021-21290?

CVE-2021-21290 is a medium-severity vulnerability in Debian Debian Linux, published on 8 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to information disclosure. Of note, this does not impact modern MacOS Operating Systems. The method "File.createTempFile" on unix-like systems creates a random file, but, by default will create this file with the permissions "-rw-r--r--". Thus, if sensitive information is written to this file, other local users can read this information. This is the case in netty's "AbstractDiskHttpData" is vulnerable. This has been fixed in version 4.1.59.Final. As a workaround, one may specify your own "java.io.tmpdir" when you start the JVM or use "DefaultHttpDataFactory.setBaseDir(...)" to set the directory to something that is only readable by the current user.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-379 (Creation of Temporary File in Directory with Insecure Permissions), CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2021-21290?

6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-codec-http and org.jboss.netty:netty. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty-codec-http` | Maven | From 4.0.0 | 4.1.59.Final |
| `io.netty:netty-codec-http` | Maven | From 4.0.0 | 4.1.59.Final |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `satellite` | Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
| `satellite-cli` | Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
| `satellite-common` | Red Hat:satellite:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
| `satellite` | Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
| `satellite-capsule` | Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |
| `satellite-common` | Red Hat:satellite_capsule:6.10::el7 | All versions | 0:6.10.2-1.el7sat |

Products: Debian Debian Linux, Netapp Active Iq Unified Manager, Netapp Cloud Secure Agent, Netapp Snapcenter, Netty Netty, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Trade Finance Process Management, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Design Studio, Oracle Communications Messaging Server, Oracle Nosql Database, Quarkus Quarkus.

## How do I fix CVE-2021-21290?

Upgrade to a fixed version.

## Is CVE-2021-21290 being exploited?

There is no known exploitation of CVE-2021-21290 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21290 and fix it if it is affected.

What it is: CVE-2021-21290 is a medium-severity vulnerability in Debian Debian Linux, published on 8 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21290 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty-codec-http (Maven): affected from 4.0.0; fixed in 4.1.59.Final
- io.netty:netty-codec-http (Maven): affected from 4.0.0; fixed in 4.1.59.Final
- org.jboss.netty:netty (Maven): affected all versions; no fix listed
- org.jboss.netty:netty (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21290/ (Markdown: https://insights.sbomify.com/CVE-2021-21290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21290
- OSV: https://osv.dev/vulnerability/CVE-2021-21290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21290/
Summaries are generated and may contain mistakes; the official description above is the record.
