CVE-2021-21293 Unbounded connection acceptance leads to file handle exhaustion
Attackers can exhaust file handles by opening unlimited connections, causing denial of service in applications using the blaze Scala library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21293?
CVE-2021-21293 is a high-severity denial of service vulnerability in http4s blaze, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. All servers running blaze-core before version 0.14.15 are affected by a vulnerability in which unbounded connection acceptance leads to file handle exhaustion. Blaze, accepts connections unconditionally on a dedicated thread pool. This has the net effect of amplifying degradation in services that are unable to handle their current request load, since incoming connections are still accepted and added to an unbounded queue. Each connection allocates a socket handle, which drains a scarce OS resource. This can also confound higher level circuit breakers which work based on detecting failed connections. The vast majority of affected users are using it as part of http4s-blaze-server <= 0.21.16. http4s provides a mechanism for limiting open connections, but is enforced inside the Blaze accept loop, after the connection is accepted and the socket opened. Thus, the limit only prevents the number of connections which can be simultaneously processed, not the number of connections which can be held open. The issue is fixed in version 0.14.15 for "NIO1SocketServerGroup". A "maxConnections" parameter is added, with a default value of 512. Concurrent connections beyond this limit are rejected. To run unbounded, which is not recommended, set a negative number. The "NIO2SocketServerGroup" has no such setting and is now deprecated. There are several possible workarounds described in the refrenced GitHub Advisory GHSA-xmw9-q7x9-j5qc.
Which versions are affected by CVE-2021-21293?
6 open source packages ship an affected version, including org.http4s:blaze-core_2.11, org.http4s:blaze-core_2.12 and org.http4s:blaze-core_2.13. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:blaze-core_2.11 Maven | All versions | 0.14.15 |
org.http4s:blaze-core_2.11 Maven | All versions | 0.14.15 |
org.http4s:blaze-core_2.12 Maven | All versions | 0.14.15 |
org.http4s:blaze-core_2.12 Maven | All versions | 0.14.15 |
org.http4s:blaze-core_2.13 Maven | All versions | 0.14.15 |
org.http4s:blaze-core_2.13 Maven | All versions | 0.14.15 |
Products include Typelevel Blaze.
How do I fix CVE-2021-21293?
Upgrade org.http4s:blaze-core_2.11 to 0.14.15 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-21293 being exploited?
There is no known exploitation of CVE-2021-21293 in the wild and no public exploit code.
Sources
Also known as GHSA-xmw9-q7x9-j5qc.