# CVE-2021-21293: Unbounded connection acceptance leads to file handle exhaustion

> Attackers can exhaust file handles by opening unlimited connections, causing denial of service in applications using the blaze Scala library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xmw9-q7x9-j5qc

## What is CVE-2021-21293?

CVE-2021-21293 is a high-severity denial of service vulnerability in http4s blaze, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. All servers running blaze-core before version 0.14.15 are affected by a vulnerability in which unbounded connection acceptance leads to file handle exhaustion. Blaze, accepts connections unconditionally on a dedicated thread pool. This has the net effect of amplifying degradation in services that are unable to handle their current request load, since incoming connections are still accepted and added to an unbounded queue. Each connection allocates a socket handle, which drains a scarce OS resource. This can also confound higher level circuit breakers which work based on detecting failed connections. The vast majority of affected users are using it as part of http4s-blaze-server <= 0.21.16. http4s provides a mechanism for limiting open connections, but is enforced inside the Blaze accept loop, after the connection is accepted and the socket opened. Thus, the limit only prevents the number of connections which can be simultaneously processed, not the number of connections which can be held open. The issue is fixed in version 0.14.15 for "NIO1SocketServerGroup". A "maxConnections" parameter is added, with a default value of 512. Concurrent connections beyond this limit are rejected. To run unbounded, which is not recommended, set a negative number. The "NIO2SocketServerGroup" has no such setting and is now deprecated. There are several possible workarounds described in the refrenced GitHub Advisory GHSA-xmw9-q7x9-j5qc.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21293?

6 open source packages ship an affected version, including org.http4s:blaze-core_2.11, org.http4s:blaze-core_2.12 and org.http4s:blaze-core_2.13. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:blaze-core_2.11` | Maven | All versions | 0.14.15 |
| `org.http4s:blaze-core_2.11` | Maven | All versions | 0.14.15 |
| `org.http4s:blaze-core_2.12` | Maven | All versions | 0.14.15 |
| `org.http4s:blaze-core_2.12` | Maven | All versions | 0.14.15 |
| `org.http4s:blaze-core_2.13` | Maven | All versions | 0.14.15 |
| `org.http4s:blaze-core_2.13` | Maven | All versions | 0.14.15 |

Products: Typelevel Blaze.

## How do I fix CVE-2021-21293?

Upgrade org.http4s:blaze-core_2.11 to 0.14.15 or later.

## Is CVE-2021-21293 being exploited?

There is no known exploitation of CVE-2021-21293 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21293 and fix it if it is affected.

What it is: CVE-2021-21293 is a high-severity denial of service vulnerability in http4s blaze, published on 2 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21293 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:blaze-core_2.11 (Maven): affected all versions; fixed in 0.14.15
- org.http4s:blaze-core_2.11 (Maven): affected all versions; fixed in 0.14.15
- org.http4s:blaze-core_2.12 (Maven): affected all versions; fixed in 0.14.15
- org.http4s:blaze-core_2.12 (Maven): affected all versions; fixed in 0.14.15
- org.http4s:blaze-core_2.13 (Maven): affected all versions; fixed in 0.14.15
- org.http4s:blaze-core_2.13 (Maven): affected all versions; fixed in 0.14.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21293/ (Markdown: https://insights.sbomify.com/CVE-2021-21293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21293
- OSV: https://osv.dev/vulnerability/CVE-2021-21293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21293/
Summaries are generated and may contain mistakes; the official description above is the record.
