{"answers":{"affected":"7 open source packages ship an affected version, including io.netty:netty, zookeeper and io.netty:netty-codec-http2. It affects 8 products.","exploited":"There is no known exploitation of CVE-2021-21295 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-21295 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Mar 2021."},"fix_prompt":"Check this codebase for CVE-2021-21295 and fix it if it is affected.\n\nWhat it is: CVE-2021-21295 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Mar 2021. \nExploitation: There is no known exploitation of CVE-2021-21295 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.netty:netty (Maven): affected all versions; no fix listed\n- io.netty:netty (Maven): affected all versions; no fix listed\n- zookeeper (Bitnami): affected from 3.5.9; fixed in 3.5.10\n- io.netty:netty-codec-http2 (Maven): affected from 4.0.0; fixed in 4.1.60.Final\n- io.netty:netty-codec-http2 (Maven): affected from 4.0.0; fixed in 4.1.60.Final\n- org.jboss.netty:netty (Maven): affected all versions; no fix listed\n- org.jboss.netty:netty (Maven): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21295/ (Markdown: https://insights.sbomify.com/CVE-2021-21295/index.md)","id":"CVE-2021-21295","markdown":"https://insights.sbomify.com/CVE-2021-21295/index.md","name":"CVE-2021-21295","record":{"aliases":["BIT-zookeeper-2021-21295","CLEANSTART-2026-GV36158","DEBIAN-CVE-2021-21295","GHSA-wm47-8v5p-wjpj","UBUNTU-CVE-2021-21295","openSUSE-SU-2021:0448-1"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"kudu","vendor":"apache"},{"product":"zookeeper","vendor":"apache"},{"product":"debian_linux","vendor":"debian"},{"product":"oncommand_api_services","vendor":"netapp"},{"product":"oncommand_workflow_automation","vendor":"netapp"},{"product":"netty","vendor":"netty"},{"product":"communications_cloud_native_core_policy","vendor":"oracle"},{"product":"quarkus","vendor":"quarkus"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers \u0026 clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel's pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`.","ecosystems":["Bitnami","Maven","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible request smuggling in HTTP/2 due missing validation","id":"CVE-2021-21295","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","netapp:oncommand_workflow_automation","netty:netty","oracle:communications_cloud_native_core_policy"],"type":null,"year":"2021"},"n_packages":8,"n_references":91,"next":{"headline":"Denial-of-service in Fleet","id":"CVE-2021-21296"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.10"],"introduced":["3.5.9"],"last_affected":[],"package":"zookeeper","purl":"pkg:bitnami/zookeeper","source":"BIT-zookeeper-2021-21295"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"io.netty:netty","purl":null,"source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"io.netty:netty","purl":"pkg:maven/io.netty/netty","source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"Maven","fixed":["4.1.60.Final"],"introduced":["4.0.0"],"last_affected":[],"package":"io.netty:netty-codec-http2","purl":null,"source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"Maven","fixed":["4.1.60.Final"],"introduced":["4.0.0"],"last_affected":[],"package":"io.netty:netty-codec-http2","purl":"pkg:maven/io.netty/netty-codec-http2","source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"org.jboss.netty:netty","purl":null,"source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":[],"package":"org.jboss.netty:netty","purl":"pkg:maven/org.jboss.netty/netty","source":"GHSA-wm47-8v5p-wjpj"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["4.1.13-lp152.3.3.1"],"introduced":["0"],"last_affected":[],"package":"netty","purl":"pkg:rpm/opensuse/netty\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0448-1"}],"prev":{"headline":"Unbounded connection acceptance in http4s-blaze-server","id":"CVE-2021-21294"},"products":["io.netty:netty-codec-http2"],"published":"2021-03-09","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["netty"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-21295/"}