{"answers":{"affected":"2 open source packages ship an affected version, including @node-red/runtime. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21297 in the wild and no public exploit code.","fix":"Upgrade @node-red/runtime to 1.2.8 or later.","what":"CVE-2021-21297 is a high-severity code injection vulnerability in node-red, published on 26 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21297 and fix it if it is affected.\n\nWhat it is: CVE-2021-21297 is a high-severity code injection vulnerability in node-red, published on 26 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21297 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @node-red/runtime (npm): affected all versions; fixed in 1.2.8\n- @node-red/runtime (npm): affected all versions; fixed in 1.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21297/ (Markdown: https://insights.sbomify.com/CVE-2021-21297/index.md)","id":"CVE-2021-21297","markdown":"https://insights.sbomify.com/CVE-2021-21297/index.md","name":"CVE-2021-21297","record":{"aliases":["GHSA-xp9c-82x8-7f67"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node-RED low-code platform","requires_auth":"low_privilege","summary":"Attackers can exploit prototype pollution in the admin API to modify runtime behavior, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node-red","vendor":"nodered"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype Pollution in Node-Red","id":"CVE-2021-21297","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal in Node-Red","id":"CVE-2021-21298"},"packages":[{"ecosystem":"npm","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"@node-red/runtime","purl":null,"source":"GHSA-xp9c-82x8-7f67"},{"ecosystem":"npm","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"@node-red/runtime","purl":"pkg:npm/%40node-red/runtime","source":"GHSA-xp9c-82x8-7f67"}],"prev":{"headline":"Denial-of-service in Fleet","id":"CVE-2021-21296"},"products":["node-red"],"published":"2021-02-26","related":[{"cvss_score":5.4,"headline":"Cross-Site Scripting in node-red","id":"CVE-2019-15607","kev_date_added":null,"published":"2020-01-28"},{"cvss_score":3.5,"headline":"Path traversal in Node-Red","id":"CVE-2021-21298","kev_date_added":null,"published":"2021-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["node-red"]},"summary":"Attackers can exploit prototype pollution in the admin API to modify runtime behavior, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2021-21297/"}