# CVE-2021-21297: Prototype Pollution in Node-Red

> Attackers can exploit prototype pollution in the admin API to modify runtime behavior, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xp9c-82x8-7f67

## What is CVE-2021-21297?

CVE-2021-21297 is a high-severity code injection vulnerability in node-red, published on 26 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-21297?

2 open source packages ship an affected version, including @node-red/runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@node-red/runtime` | npm | All versions | 1.2.8 |
| `@node-red/runtime` | npm | All versions | 1.2.8 |

Products: Nodered Node-Red.

## How do I fix CVE-2021-21297?

Upgrade @node-red/runtime to 1.2.8 or later.

## Is CVE-2021-21297 being exploited?

There is no known exploitation of CVE-2021-21297 in the wild and no public exploit code.

## Other vulnerabilities in node-red

- [CVE-2019-15607](https://insights.sbomify.com/CVE-2019-15607/): Cross-Site Scripting in node-red (medium 5.4)
- [CVE-2021-21298](https://insights.sbomify.com/CVE-2021-21298/): Path traversal in Node-Red (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21297 and fix it if it is affected.

What it is: CVE-2021-21297 is a high-severity code injection vulnerability in node-red, published on 26 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21297 in the wild and no public exploit code.

Affected packages and fixed versions:
- @node-red/runtime (npm): affected all versions; fixed in 1.2.8
- @node-red/runtime (npm): affected all versions; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21297/ (Markdown: https://insights.sbomify.com/CVE-2021-21297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21297
- OSV: https://osv.dev/vulnerability/CVE-2021-21297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21297/
Summaries are generated and may contain mistakes; the official description above is the record.
