# CVE-2021-21298: Path traversal in Node-Red


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m33v-338h-4v9f

## What is CVE-2021-21298?

CVE-2021-21298 is a low-severity vulnerability in node-red, published on 26 Feb 2021. 

### Official description

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-21298?

2 open source packages ship an affected version, including @node-red/runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@node-red/runtime` | npm | All versions | 1.2.8 |
| `@node-red/runtime` | npm | All versions | 1.2.8 |

Products: Nodered Node-Red.

## How do I fix CVE-2021-21298?

Upgrade @node-red/runtime to 1.2.8 or later.

## Is CVE-2021-21298 being exploited?

There is no known exploitation of CVE-2021-21298 in the wild and no public exploit code.

## Other vulnerabilities in node-red

- [CVE-2021-21297](https://insights.sbomify.com/CVE-2021-21297/): Prototype Pollution in Node-Red (high 7.7)
- [CVE-2019-15607](https://insights.sbomify.com/CVE-2019-15607/): Cross-Site Scripting in node-red (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21298 and fix it if it is affected.

What it is: CVE-2021-21298 is a low-severity vulnerability in node-red, published on 26 Feb 2021. 
Exploitation: There is no known exploitation of CVE-2021-21298 in the wild and no public exploit code.

Affected packages and fixed versions:
- @node-red/runtime (npm): affected all versions; fixed in 1.2.8
- @node-red/runtime (npm): affected all versions; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21298/ (Markdown: https://insights.sbomify.com/CVE-2021-21298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21298
- OSV: https://osv.dev/vulnerability/CVE-2021-21298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21298/
Summaries are generated and may contain mistakes; the official description above is the record.
