CVE-2021-21299 Multiple Transfer-Encoding headers misinterprets request payload
Hyper library allows request smuggling via multiple Transfer-Encoding headers when used behind a vulnerable proxy, enabling cache poisoning or access control bypass.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21299?
CVE-2021-21299 is a medium-severity vulnerability in hyperium hyper, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.
Weakness: CWE-444
Which versions are affected by CVE-2021-21299?
7 open source packages ship an affected version, including hyper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
hyper crates.io | From 0.12.0 | 0.12.36, 0.13.10, 0.14.3 |
hyper crates.io | From 0.12.0 | 0.12.36 |
hyper crates.io | From 0.12.0 | 0.12.36 |
hyper crates.io | From 0.13.0 | 0.13.10 |
hyper crates.io | From 0.13.0 | 0.13.10 |
hyper crates.io | From 0.14.0 | 0.14.3 |
1 more packages
hyper crates.io | From 0.14.0 | 0.14.3 |
Linux distribution packages (3)
spotifyd openSUSE:Tumbleweed | All versions | 0.3.3-9.1 |
tuigreet openSUSE:Tumbleweed | All versions | 0.7.1-6.1 |
wayshot openSUSE:Tumbleweed | All versions | 1.1.9-1.1 |
Products include Hyper Hyper.
How do I fix CVE-2021-21299?
Upgrade hyper to a fixed version for your release line: 0.12.36, 0.13.10 or 0.14.3.
Is CVE-2021-21299 being exploited?
There is no known exploitation of CVE-2021-21299 in the wild and no public exploit code.
Other vulnerabilities in hyperium hyper
- CVE-2020-35863 HTTP Request Smuggling in hyper
- CVE-2022-31394 Denial of service in n/a
- CVE-2021-32714 Integer Overflow in Chunked Transfer-Encoding
- CVE-2017-18587 Headers containing newline characters can split messages in hyper
- CVE-2016-10932 HTTPS MitM vulnerability due to lack of hostname verification
Sources
Also known as CVE-2021-26959, DEBIAN-CVE-2021-21299, GHSA-6hfq-h8hq-87mf, RUSTSEC-2021-0020, UBUNTU-CVE-2021-21299, openSUSE-SU-2024:12238-1 and 2 more.