# CVE-2021-21299: Multiple Transfer-Encoding headers misinterprets request payload

> Hyper library allows request smuggling via multiple Transfer-Encoding headers when used behind a vulnerable proxy, enabling cache poisoning or access control bypass.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CVE-2021-26959, DEBIAN-CVE-2021-21299, GHSA-6hfq-h8hq-87mf, RUSTSEC-2021-0020, UBUNTU-CVE-2021-21299, openSUSE-SU-2024:12238-1, openSUSE-SU-2024:12239-1, openSUSE-SU-2024:12274-1

## What is CVE-2021-21299?

CVE-2021-21299 is a medium-severity vulnerability in hyperium hyper, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2021-21299?

7 open source packages ship an affected version, including hyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hyper` | crates.io | From 0.12.0 | 0.12.36, 0.13.10, 0.14.3 |
| `hyper` | crates.io | From 0.12.0 | 0.12.36 |
| `hyper` | crates.io | From 0.12.0 | 0.12.36 |
| `hyper` | crates.io | From 0.13.0 | 0.13.10 |
| `hyper` | crates.io | From 0.13.0 | 0.13.10 |
| `hyper` | crates.io | From 0.14.0 | 0.14.3 |
| `hyper` | crates.io | From 0.14.0 | 0.14.3 |
| `spotifyd` | openSUSE:Tumbleweed | All versions | 0.3.3-9.1 |
| `tuigreet` | openSUSE:Tumbleweed | All versions | 0.7.1-6.1 |
| `wayshot` | openSUSE:Tumbleweed | All versions | 1.1.9-1.1 |

Products: Hyper Hyper.

## How do I fix CVE-2021-21299?

Upgrade hyper to a fixed version for your release line: 0.12.36, 0.13.10 or 0.14.3.

## Is CVE-2021-21299 being exploited?

There is no known exploitation of CVE-2021-21299 in the wild and no public exploit code.

## Other vulnerabilities in hyperium hyper

- [CVE-2020-35863](https://insights.sbomify.com/CVE-2020-35863/): HTTP Request Smuggling in hyper (critical 9.8)
- [CVE-2022-31394](https://insights.sbomify.com/CVE-2022-31394/): Denial of service in n/a (high 7.5)
- [CVE-2021-32714](https://insights.sbomify.com/CVE-2021-32714/): Integer Overflow in Chunked Transfer-Encoding (medium 5.9)
- [CVE-2017-18587](https://insights.sbomify.com/CVE-2017-18587/): Headers containing newline characters can split messages in hyper (medium 5.3)
- [CVE-2016-10932](https://insights.sbomify.com/CVE-2016-10932/): HTTPS MitM vulnerability due to lack of hostname verification (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21299 and fix it if it is affected.

What it is: CVE-2021-21299 is a medium-severity vulnerability in hyperium hyper, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21299 in the wild and no public exploit code.

Affected packages and fixed versions:
- hyper (crates.io): affected from 0.12.0; fixed in 0.12.36, 0.13.10, 0.14.3
- hyper (crates.io): affected from 0.12.0; fixed in 0.12.36
- hyper (crates.io): affected from 0.12.0; fixed in 0.12.36
- hyper (crates.io): affected from 0.13.0; fixed in 0.13.10
- hyper (crates.io): affected from 0.13.0; fixed in 0.13.10
- hyper (crates.io): affected from 0.14.0; fixed in 0.14.3
- hyper (crates.io): affected from 0.14.0; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21299/ (Markdown: https://insights.sbomify.com/CVE-2021-21299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21299
- OSV: https://osv.dev/vulnerability/CVE-2021-21299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21299/
Summaries are generated and may contain mistakes; the official description above is the record.
