CVE-2021-21303 Injection attack in Helm
Attackers can inject terminal escape sequences via unsanitized Helm chart metadata, potentially altering or obscuring terminal output.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21303?
CVE-2021-21303 is a medium-severity vulnerability in helm, published on 5 Feb 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Helm is open-source software which is essentially "The Kubernetes Package Manager". Helm is a tool for managing Charts. Charts are packages of pre-configured Kubernetes resources. In Helm from version 3.0 and before version 3.5.2, there a few cases where data loaded from potentially untrusted sources was not properly sanitized. When a SemVer in the `version` field of a chart is invalid, in some cases Helm allows the string to be used "as is" without sanitizing. Helm fails to properly sanitized some fields present on Helm repository `index.yaml` files. Helm does not properly sanitized some fields in the `plugin.yaml` file for plugins In some cases, Helm does not properly sanitize the fields in the `Chart.yaml` file. By exploiting these attack vectors, core maintainers were able to send deceptive information to a terminal screen running the `helm` command, as well as obscure or alter information on the screen. In some cases, we could send codes that terminals used to execute higher-order logic, like clearing a terminal screen. Further, during evaluation, the Helm maintainers discovered a few other fields that were not properly sanitized when read out of repository index files. This fix remedies all such cases, and once again enforces SemVer2 policies on version fields. All users of the Helm 3 should upgrade to the fixed version 3.5.2 or later. Those who use Helm as a library should verify that they either sanitize this data on their own, or use the proper Helm API calls to sanitize the data.
Weakness: CWE-74
Which versions are affected by CVE-2021-21303?
4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm/v3 Go | From 3.0.0 | 3.5.2 |
helm.sh/helm/v3 Go | From 3.0.0 | 3.5.2 |
helm.sh/helm/v3 Go | From 3.0.0 | 3.5.2 |
helm Bitnami | From 3.0.0 | 3.5.2 |
Products include Helm Helm.
How do I fix CVE-2021-21303?
Upgrade helm.sh/helm/v3 to 3.5.2 or later.
Is CVE-2021-21303 being exploited?
There is no known exploitation of CVE-2021-21303 in the wild and no public exploit code.
Other vulnerabilities in helm
- CVE-2019-18658 Helm Unsafe Link Following
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- CVE-2020-11013 lookup Function Information Discolosure in Helm
Sources
Also known as AZL-6470, BIT-helm-2021-21303, GHSA-c38g-469g-cmgx, GO-2022-1040, UBUNTU-CVE-2021-21303.