{"answers":{"affected":"2 open source packages ship an affected version, including dynamoose. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21304 in the wild and no public exploit code.","fix":"Upgrade dynamoose to 2.7.0 or later.","what":"CVE-2021-21304 is a high-severity vulnerability in dynamoose, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21304 and fix it if it is affected.\n\nWhat it is: CVE-2021-21304 is a high-severity vulnerability in dynamoose, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21304 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dynamoose (npm): affected from 2.0.0; fixed in 2.7.0\n- dynamoose (npm): affected from 2.0.0; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21304/ (Markdown: https://insights.sbomify.com/CVE-2021-21304/index.md)","id":"CVE-2021-21304","markdown":"https://insights.sbomify.com/CVE-2021-21304/index.md","name":"CVE-2021-21304","record":{"aliases":["GHSA-rrqm-p222-8ph2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"DynamoDB modeling library","requires_auth":"none","summary":"Prototype pollution in Dynamoose allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dynamoose","vendor":"dynamoosejs"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method \"lib/utils/object/set.ts\". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype Pollution in Dynamoose","id":"CVE-2021-21304","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Code Injection vulnerability in CarrierWave","id":"CVE-2021-21305"},"packages":[{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["2.0.0"],"last_affected":[],"package":"dynamoose","purl":null,"source":"GHSA-rrqm-p222-8ph2"},{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["2.0.0"],"last_affected":[],"package":"dynamoose","purl":"pkg:npm/dynamoose","source":"GHSA-rrqm-p222-8ph2"}],"prev":{"headline":"Injection attack in Helm","id":"CVE-2021-21303"},"products":["dynamoose"],"published":"2021-02-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["dynamoose"]},"summary":"Prototype pollution in Dynamoose allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2021-21304/"}