{"answers":{"affected":"4 open source packages ship an affected version, including carrierwave. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21305 in the wild and no public exploit code.","fix":"Upgrade carrierwave to a fixed version for your release line: 1.3.2 or 2.1.1.","what":"CVE-2021-21305 is a high-severity code injection vulnerability in carrierwaveuploader carrierwave, published on 8 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21305 and fix it if it is affected.\n\nWhat it is: CVE-2021-21305 is a high-severity code injection vulnerability in carrierwaveuploader carrierwave, published on 8 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21305 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- carrierwave (RubyGems): affected all versions; fixed in 1.3.2\n- carrierwave (RubyGems): affected all versions; fixed in 1.3.2\n- carrierwave (RubyGems): affected from 2.0.0; fixed in 2.1.1\n- carrierwave (RubyGems): affected from 2.0.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21305/ (Markdown: https://insights.sbomify.com/CVE-2021-21305/index.md)","id":"CVE-2021-21305","markdown":"https://insights.sbomify.com/CVE-2021-21305/index.md","name":"CVE-2021-21305","record":{"aliases":["DEBIAN-CVE-2021-21305","GHSA-cf3w-g86h-35x4","UBUNTU-CVE-2021-21305"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby file upload library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary Ruby code via crafted mutation options in CarrierWave if developers supply untrusted inputs to these options.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"carrierwave","vendor":"carrierwave_project"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The \"#manipulate!\" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code Injection vulnerability in CarrierWave","id":"CVE-2021-21305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Denial of Service in Marked","id":"CVE-2021-21306"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"carrierwave","purl":null,"source":"GHSA-cf3w-g86h-35x4"},{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"carrierwave","purl":"pkg:gem/carrierwave","source":"GHSA-cf3w-g86h-35x4"},{"ecosystem":"RubyGems","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"carrierwave","purl":null,"source":"GHSA-cf3w-g86h-35x4"},{"ecosystem":"RubyGems","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"carrierwave","purl":"pkg:gem/carrierwave","source":"GHSA-cf3w-g86h-35x4"}],"prev":{"headline":"Prototype Pollution in Dynamoose","id":"CVE-2021-21304"},"products":["carrierwave"],"published":"2021-02-08","related":[{"cvss_score":6.8,"headline":"CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained","id":"CVE-2024-29034","kev_date_added":null,"published":"2024-03-24"},{"cvss_score":6.8,"headline":"CarrierWave has a content-type allowlist bypass vulnerability, possibly leading to XSS","id":"CVE-2023-49090","kev_date_added":null,"published":"2023-11-29"},{"cvss_score":4.7,"headline":"CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters","id":"CVE-2026-44587","kev_date_added":null,"published":"2026-06-16"},{"cvss_score":4.3,"headline":"Server-side request forgery in CarrierWave","id":"CVE-2021-21288","kev_date_added":null,"published":"2021-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["carrierwaveuploader"]},"summary":"Attackers can execute arbitrary Ruby code via crafted mutation options in CarrierWave if developers supply untrusted inputs to these options.","url":"https://insights.sbomify.com/CVE-2021-21305/"}