# CVE-2021-21305: Code Injection vulnerability in CarrierWave

> Attackers can execute arbitrary Ruby code via crafted mutation options in CarrierWave if developers supply untrusted inputs to these options.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-21305, GHSA-cf3w-g86h-35x4, UBUNTU-CVE-2021-21305

## What is CVE-2021-21305?

CVE-2021-21305 is a high-severity code injection vulnerability in carrierwaveuploader carrierwave, published on 8 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-21305?

4 open source packages ship an affected version, including carrierwave. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `carrierwave` | RubyGems | All versions | 1.3.2 |
| `carrierwave` | RubyGems | All versions | 1.3.2 |
| `carrierwave` | RubyGems | From 2.0.0 | 2.1.1 |
| `carrierwave` | RubyGems | From 2.0.0 | 2.1.1 |

Products: Carrierwave Project Carrierwave.

## How do I fix CVE-2021-21305?

Upgrade carrierwave to a fixed version for your release line: 1.3.2 or 2.1.1.

## Is CVE-2021-21305 being exploited?

There is no known exploitation of CVE-2021-21305 in the wild and no public exploit code.

## Other vulnerabilities in carrierwaveuploader carrierwave

- [CVE-2024-29034](https://insights.sbomify.com/CVE-2024-29034/): CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained (medium 6.8)
- [CVE-2023-49090](https://insights.sbomify.com/CVE-2023-49090/): CarrierWave has a content-type allowlist bypass vulnerability, possibly leading to XSS (medium 6.8)
- [CVE-2026-44587](https://insights.sbomify.com/CVE-2026-44587/): CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters (medium 4.7)
- [CVE-2021-21288](https://insights.sbomify.com/CVE-2021-21288/): Server-side request forgery in CarrierWave (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21305 and fix it if it is affected.

What it is: CVE-2021-21305 is a high-severity code injection vulnerability in carrierwaveuploader carrierwave, published on 8 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21305 in the wild and no public exploit code.

Affected packages and fixed versions:
- carrierwave (RubyGems): affected all versions; fixed in 1.3.2
- carrierwave (RubyGems): affected all versions; fixed in 1.3.2
- carrierwave (RubyGems): affected from 2.0.0; fixed in 2.1.1
- carrierwave (RubyGems): affected from 2.0.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21305/ (Markdown: https://insights.sbomify.com/CVE-2021-21305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21305
- OSV: https://osv.dev/vulnerability/CVE-2021-21305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21305/
Summaries are generated and may contain mistakes; the official description above is the record.
