CVE-2021-21306 Denial of Service in Marked

Medium 5.3 Published Updated

Attackers can cause denial of service in applications using the Marked library by submitting specially crafted markdown input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-21306?

CVE-2021-21306 is a medium-severity denial of service vulnerability in markedjs marked, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.

Weakness: CWE-400

Which versions are affected by CVE-2021-21306?

2 open source packages ship an affected version, including marked. It affects 1 product.

PackageAffectedFixed in
marked npmFrom 1.1.12.0.0
marked npmFrom 1.1.12.0.0

Products include Marked Project Marked.

How do I fix CVE-2021-21306?

Upgrade marked to 2.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-21306 being exploited?

There is no known exploitation of CVE-2021-21306 in the wild and no public exploit code.

Sources

Also known as GHSA-4r62-v4vq-hr96.

Is CVE-2021-21306 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free