CVE-2021-21307 Remote Code Exploit in Lucee Admin

High 8.6 Published Updated

Unauthenticated attackers can execute arbitrary code on Lucee Server due to missing authorization in the Admin interface.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2021-21307?

CVE-2021-21307 is a high-severity missing authorization vulnerability in Lucee, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

Weakness: CWE-862

Which versions are affected by CVE-2021-21307?

It affects 1 product.

Products include Lucee Lucee Server.

How do I fix CVE-2021-21307?

No fix has been published for CVE-2021-21307 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-21307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21307 exists.

Public exploit code: 1 Metasploit module and 1 Nuclei template.

Sources

Also known as GHSA-2xvv-723c-8p7r.

Is CVE-2021-21307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free