# CVE-2021-21307: Remote Code Exploit in Lucee Admin

> Unauthenticated attackers can execute arbitrary code on Lucee Server due to missing authorization in the Admin interface.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2xvv-723c-8p7r

## What is CVE-2021-21307?

CVE-2021-21307 is a high-severity missing authorization vulnerability in Lucee, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2021-21307?

It affects 1 product.


Products: Lucee Lucee Server.

## How do I fix CVE-2021-21307?

No fix has been published for CVE-2021-21307 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21307 exists.

Public exploit code:

- Lucee Administrator imgProcess.cfm Arbitrary File Write (metasploit)
- Lucee Admin - Remote Code Execution (nuclei): http/cves/2021/CVE-2021-21307.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21307 and fix it if it is affected.

What it is: CVE-2021-21307 is a high-severity missing authorization vulnerability in Lucee, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21307 exists.

Affected product: Lucee. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21307/ (Markdown: https://insights.sbomify.com/CVE-2021-21307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21307
- OSV: https://osv.dev/vulnerability/CVE-2021-21307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21307/
Summaries are generated and may contain mistakes; the official description above is the record.
