# CVE-2021-21308: Improper session management for soft logout

> Attackers can bypass soft logout mechanisms to execute customer commands, potentially leading to account takeover and data modification.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-557h-hf3c-whcg

## What is CVE-2021-21308?

CVE-2021-21308 is a medium-severity authentication bypass vulnerability in Prestashop Prestashop, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PrestaShop is a fully scalable open source e-commerce solution. In PrestaShop before version 1.7.2 the soft logout system is not complete and an attacker is able to foreign request and executes customer commands. The problem is fixed in 1.7.7.2

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-21308?

It affects 1 product.


Products: Prestashop Prestashop.

## How do I fix CVE-2021-21308?

No fix has been published for CVE-2021-21308 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21308 being exploited?

There is no known exploitation of CVE-2021-21308 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21308 and fix it if it is affected.

What it is: CVE-2021-21308 is a medium-severity authentication bypass vulnerability in Prestashop Prestashop, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21308 in the wild and no public exploit code.

Affected product: Prestashop Prestashop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21308/ (Markdown: https://insights.sbomify.com/CVE-2021-21308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21308
- OSV: https://osv.dev/vulnerability/CVE-2021-21308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21308/
Summaries are generated and may contain mistakes; the official description above is the record.
