# CVE-2021-21310: Token verification bug in next-auth

> Attackers can sign in as other users by exploiting a token verification flaw in the Prisma adapter with Email provider.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pg53-56cg-4m8q

## What is CVE-2021-21310?

CVE-2021-21310 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. In next-auth before version 3.3.0 there is a token verification vulnerability. Implementations using the Prisma database adapter in conjunction with the Email provider are impacted. Implementations using the Email provider with the default database adapter are not impacted. Implementations using the Prisma database adapter but not using the Email provider are not impacted. The Prisma database adapter was checking the verification token, but was not verifying the email address associated with that token. This made it possible to use a valid token to sign in as another user when using the Prima adapter in conjunction with the Email provider. This issue is specific to the community supported Prisma adapter. This issue is fixed in version 3.3.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2021-21310?

2 open source packages ship an affected version, including next-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-auth` | npm | All versions | 3.3.0 |
| `next-auth` | npm | All versions | 3.3.0 |

Products: Nextauth.js Next-Auth.

## How do I fix CVE-2021-21310?

Upgrade next-auth to 3.3.0 or later.

## Is CVE-2021-21310 being exploited?

There is no known exploitation of CVE-2021-21310 in the wild and no public exploit code.

## Other vulnerabilities in nextauthjs next-auth

- [CVE-2022-35924](https://insights.sbomify.com/CVE-2022-35924/): Verification requests (magic link) sent to unwanted emails (critical 9.1)
- [CVE-2023-27490](https://insights.sbomify.com/CVE-2023-27490/): Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth (high 8.1)
- [CVE-2022-31093](https://insights.sbomify.com/CVE-2022-31093/): Improper Handling of `callbackUrl` parameter in next-auth (high 7.5)
- [CVE-2022-31127](https://insights.sbomify.com/CVE-2022-31127/): Improper handling of email input in next-auth (high 7.1)
- [CVE-2022-39263](https://insights.sbomify.com/CVE-2022-39263/): NextAuth.js Upstash Adapter missing token verification (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21310 and fix it if it is affected.

What it is: CVE-2021-21310 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21310 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-auth (npm): affected all versions; fixed in 3.3.0
- next-auth (npm): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21310/ (Markdown: https://insights.sbomify.com/CVE-2021-21310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21310
- OSV: https://osv.dev/vulnerability/CVE-2021-21310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21310/
Summaries are generated and may contain mistakes; the official description above is the record.
