CVE-2021-21311 Adminer Server-Side Request Forgery

Exploited in the wild High 7.2 Published Updated

Server-side request forgery in Adminer allows attackers to interact with internal services when using the bundled driver version.

Exploited in the wild
Since 29 Sep 2025
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-21311?

CVE-2021-21311 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

Weakness: CWE-918

Which versions are affected by CVE-2021-21311?

2 open source packages ship an affected version, including vrana/adminer. It affects 2 products.

PackageAffectedFixed in
vrana/adminer PackagistAll versions4.7.9
vrana/adminer PackagistAll versions4.7.9

Products include Adminer Adminer, Debian Debian Linux.

How do I fix CVE-2021-21311?

Upgrade vrana/adminer to 4.7.9 or later. US federal agencies must fix it by 20 Oct 2025.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2021-21311 being exploited?

Yes. Attackers have exploited CVE-2021-21311 in the wild since at least 29 Sep 2025.

Public exploit code: 1 Nuclei template and 3 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2021-21311, DLA-2580-1, GHSA-x5r2-hj5c-8jx6, UBUNTU-CVE-2021-21311.

Is CVE-2021-21311 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free