{"answers":{"affected":"2 open source packages ship an affected version, including vrana/adminer. It affects 2 products.","exploited":"Yes. Attackers have exploited CVE-2021-21311 in the wild since at least 29 Sep 2025.","fix":"Upgrade vrana/adminer to 4.7.9 or later. US federal agencies must fix it by 20 Oct 2025.","what":"CVE-2021-21311 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21311 and fix it if it is affected.\n\nWhat it is: CVE-2021-21311 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2021-21311 in the wild since at least 29 Sep 2025.\n\nAffected packages and fixed versions:\n- vrana/adminer (Packagist): affected all versions; fixed in 4.7.9\n- vrana/adminer (Packagist): affected all versions; fixed in 4.7.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21311/ (Markdown: https://insights.sbomify.com/CVE-2021-21311/index.md)","id":"CVE-2021-21311","markdown":"https://insights.sbomify.com/CVE-2021-21311/index.md","name":"CVE-2021-21311","record":{"aliases":["DEBIAN-CVE-2021-21311","DLA-2580-1","GHSA-x5r2-hj5c-8jx6","UBUNTU-CVE-2021-21311"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Database management tool","requires_auth":"none","summary":"Server-side request forgery in Adminer allows attackers to interact with internal services when using the bundled driver version.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"adminer","vendor":"adminer"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2022-02-14","github_poc":3,"max_poc_stars":8,"metasploit":0,"nuclei":1,"refs":[{"date":"2022-02-14T18:54:53Z","kind":"github_poc","ref":"https://github.com/llhala/CVE-2021-21311","stars":8,"title":"Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9."},{"date":"2023-06-12T13:32:52Z","kind":"github_poc","ref":"https://github.com/omoknooni/CVE-2021-21311","stars":3,"title":null},{"date":"2026-01-24T12:57:16Z","kind":"github_poc","ref":"https://github.com/Sudo-WP/sudowp-adminer","stars":1,"title":"A secure, zero-trust database management tool for WordPress. Fixes critical SSRF vulnerabilities (CVE-2021-21311) by enforcing local connections only."},{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-21311.yaml","stars":null,"title":"Adminer \u003c4.7.9 - Server-Side Request Forgery"}],"tier":"exploited"},"has_fix":true,"headline":"Adminer Server-Side Request Forgery","id":"CVE-2021-21311","indexable":true,"kev":{"dateAdded":"2025-09-29","dueDate":"2025-10-20","knownRansomwareCampaignUse":"Unknown","product":"Adminer","requiredAction":"Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.","vendorProject":"Adminer","vulnerabilityName":"Adminer Server-Side Request Forgery Vulnerability"},"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"ssrf","year":"2021"},"n_packages":2,"n_references":5,"next":{"headline":"Stored XSS on documents","id":"CVE-2021-21312"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.9"],"introduced":["0"],"last_affected":[],"package":"vrana/adminer","purl":null,"source":"GHSA-x5r2-hj5c-8jx6"},{"ecosystem":"Packagist","fixed":["4.7.9"],"introduced":["0"],"last_affected":[],"package":"vrana/adminer","purl":"pkg:composer/vrana/adminer","source":"GHSA-x5r2-hj5c-8jx6"}],"prev":{"headline":"Token verification bug in next-auth","id":"CVE-2021-21310"},"products":["adminer"],"published":"2021-02-11","related":[{"cvss_score":9.8,"headline":"vrana/adminer vulnerable to SSRF by connecting to privileged ports","id":"CVE-2018-7667","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":8.6,"headline":"Adminer PHP Object Injection issue leads to Denial of Service","id":"CVE-2025-43960","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":7.5,"headline":"Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint","id":"CVE-2026-25892","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":7.5,"headline":"Files or Directories Accessible to External Parties in Adminer","id":"CVE-2021-43008","kev_date_added":null,"published":"2022-04-05"},{"cvss_score":7.5,"headline":"XSS in doc_link","id":"CVE-2021-29625","kev_date_added":null,"published":"2021-05-19"},{"cvss_score":6.1,"headline":"vrana/adminer via XSS in the history parameter in SQL command","id":"CVE-2020-35572","kev_date_added":null,"published":"2021-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["vrana"]},"summary":"Server-side request forgery in Adminer allows attackers to interact with internal services when using the bundled driver version.","url":"https://insights.sbomify.com/CVE-2021-21311/"}