{"answers":{"affected":"2 open source packages ship an affected version, including uap-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21317 in the wild and no public exploit code.","fix":"Upgrade uap-core to 0.11.0 or later.","what":"CVE-2021-21317 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 16 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21317 and fix it if it is affected.\n\nWhat it is: CVE-2021-21317 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 16 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21317 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uap-core (npm): affected all versions; fixed in 0.11.0\n- uap-core (npm): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21317/ (Markdown: https://insights.sbomify.com/CVE-2021-21317/index.md)","id":"CVE-2021-21317","markdown":"https://insights.sbomify.com/CVE-2021-21317/index.md","name":"CVE-2021-21317","record":{"aliases":["GHSA-p4pj-mg4r-x6v4","UBUNTU-CVE-2021-21317"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"User agent parser library","requires_auth":"none","summary":"Remote attackers can cause server overload via malicious User-Agent headers due to inefficient regexes in the uap-core library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uap-core","vendor":"uap-core_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in uap-core","id":"CVE-2021-21317","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Removing access may not effect published series","id":"CVE-2021-21318"},"packages":[{"ecosystem":"npm","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":null,"source":"GHSA-p4pj-mg4r-x6v4"},{"ecosystem":"npm","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":"pkg:npm/uap-core","source":"GHSA-p4pj-mg4r-x6v4"}],"prev":{"headline":"Arbitrary code execution in less-openui5","id":"CVE-2021-21316"},"products":["uap-core"],"published":"2021-02-16","related":[{"cvss_score":5.7,"headline":"Denial of Service in uap-core when processing crafted User-Agent strings","id":"CVE-2020-5243","kev_date_added":null,"published":"2020-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["ua-parser"]},"summary":"Remote attackers can cause server overload via malicious User-Agent headers due to inefficient regexes in the uap-core library.","url":"https://insights.sbomify.com/CVE-2021-21317/"}