# CVE-2021-21317: Denial of Service in uap-core

> Remote attackers can cause server overload via malicious User-Agent headers due to inefficient regexes in the uap-core library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p4pj-mg4r-x6v4, UBUNTU-CVE-2021-21317

## What is CVE-2021-21317?

CVE-2021-21317 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 16 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21317?

2 open source packages ship an affected version, including uap-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uap-core` | npm | All versions | 0.11.0 |
| `uap-core` | npm | All versions | 0.11.0 |

Products: Uap-Core Project Uap-Core.

## How do I fix CVE-2021-21317?

Upgrade uap-core to 0.11.0 or later.

## Is CVE-2021-21317 being exploited?

There is no known exploitation of CVE-2021-21317 in the wild and no public exploit code.

## Other vulnerabilities in ua-parser uap-core

- [CVE-2020-5243](https://insights.sbomify.com/CVE-2020-5243/): Denial of Service in uap-core when processing crafted User-Agent strings (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21317 and fix it if it is affected.

What it is: CVE-2021-21317 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 16 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21317 in the wild and no public exploit code.

Affected packages and fixed versions:
- uap-core (npm): affected all versions; fixed in 0.11.0
- uap-core (npm): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21317/ (Markdown: https://insights.sbomify.com/CVE-2021-21317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21317
- OSV: https://osv.dev/vulnerability/CVE-2021-21317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21317/
Summaries are generated and may contain mistakes; the official description above is the record.
