# CVE-2021-21318: Removing access may not effect published series

> Attackers can retain unauthorized access to series metadata by exploiting flawed access control updates during episode removal or republishing.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vpc2-3wcv-qj4w

## What is CVE-2021-21318?

CVE-2021-21318 is a medium-severity missing authorization vulnerability in opencast, published on 18 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. In Opencast before version 9.2 there is a vulnerability in which publishing an episode with strict access rules will overwrite the currently set series access. This allows for an easy denial of access for all users without superuser privileges, effectively hiding the series. Access to series and series metadata on the search service (shown in media module and player) depends on the events published which are part of the series. Publishing an event will automatically publish a series and update access to it. Removing an event or republishing the event should do the same. Affected versions of Opencast may not update the series access or remove a published series if an event is being removed. On removal of an episode, this may lead to an access control list for series metadata with broader access rules than the merged access rules of all remaining events, or the series metadata still being available although all episodes of that series have been removed. This problem is fixed in Opencast 9.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-21318?

It affects 1 product.


Products: Apereo Opencast.

## How do I fix CVE-2021-21318?

No fix has been published for CVE-2021-21318 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-21318 being exploited?

There is no known exploitation of CVE-2021-21318 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21318 and fix it if it is affected.

What it is: CVE-2021-21318 is a medium-severity missing authorization vulnerability in opencast, published on 18 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21318 in the wild and no public exploit code.

Affected product: opencast. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21318/ (Markdown: https://insights.sbomify.com/CVE-2021-21318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21318
- OSV: https://osv.dev/vulnerability/CVE-2021-21318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21318/
Summaries are generated and may contain mistakes; the official description above is the record.
