{"answers":{"affected":"2 open source packages ship an affected version, including fastify-http-proxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21322 in the wild and no public exploit code.","fix":"Upgrade fastify-http-proxy to 4.3.1 or later.","what":"CVE-2021-21322 is a critical path traversal vulnerability in fastify-http-proxy, published on 2 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21322 and fix it if it is affected.\n\nWhat it is: CVE-2021-21322 is a critical path traversal vulnerability in fastify-http-proxy, published on 2 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21322 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastify-http-proxy (npm): affected all versions; fixed in 4.3.1\n- fastify-http-proxy (npm): affected all versions; fixed in 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21322/ (Markdown: https://insights.sbomify.com/CVE-2021-21322/index.md)","id":"CVE-2021-21322","markdown":"https://insights.sbomify.com/CVE-2021-21322/index.md","name":"CVE-2021-21322","record":{"aliases":["GHSA-c4qr-gmr9-v23w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify HTTP proxy plugin","requires_auth":"none","summary":"Attackers can bypass proxy prefix restrictions to access unauthorized backend paths, requiring an upgrade to the fastify-http-proxy plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastify-http-proxy","vendor":"fastify-http-proxy_project"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"fastify-http-proxy is an npm package which is a fastify plugin for proxying your http requests to another server, with hooks. By crafting a specific URL, it is possible to escape the prefix of the proxied backend service. If the base url of the proxied server is `/pub/`, a user expect that accessing `/priv` on the target service would not be possible. In affected versions, it is possible. This is fixed in version 4.3.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prefix escape","id":"CVE-2021-21322","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Regression in DNS leakage from Tor windows","id":"CVE-2021-21323"},"packages":[{"ecosystem":"npm","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"fastify-http-proxy","purl":null,"source":"GHSA-c4qr-gmr9-v23w"},{"ecosystem":"npm","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"fastify-http-proxy","purl":"pkg:npm/fastify-http-proxy","source":"GHSA-c4qr-gmr9-v23w"}],"prev":{"headline":"Prefix escape","id":"CVE-2021-21321"},"products":["fastify-http-proxy"],"published":"2021-03-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["fastify"]},"summary":"Attackers can bypass proxy prefix restrictions to access unauthorized backend paths, requiring an upgrade to the fastify-http-proxy plugin.","url":"https://insights.sbomify.com/CVE-2021-21322/"}