# CVE-2021-21328: Denial of Service

> Attackers can cause denial of service by sending unlimited requests with unique paths, exhausting system resources in Vapor apps using metrics backends.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gcj9-jj38-hwmc

## What is CVE-2021-21328?

CVE-2021-21328 is a medium-severity denial of service vulnerability in vapor, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vapor is a web framework for Swift. In Vapor before version 4.40.1, there is a DoS attack against anyone who Bootstraps a metrics backend for their Vapor app. The following is the attack vector: 1. send unlimited requests against a vapor instance with different paths. this will create unlimited counters and timers, which will eventually drain the system. 2. downstream services might suffer from this attack as well by being spammed with error paths. This has been patched in 4.40.1. The `DefaultResponder` will rewrite any undefined route paths for to `vapor_route_undefined` to avoid unlimited counters.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-21328?

2 open source packages ship an affected version, including github.com/vapor/vapor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vapor/vapor` | SwiftURL | All versions | 4.40.1 |
| `github.com/vapor/vapor` | SwiftURL | All versions | 4.40.1 |

Products: Vapor Project Vapor.

## How do I fix CVE-2021-21328?

Upgrade github.com/vapor/vapor to 4.40.1 or later.

## Is CVE-2021-21328 being exploited?

There is no known exploitation of CVE-2021-21328 in the wild and no public exploit code.

## Other vulnerabilities in vapor

- [CVE-2020-15230](https://insights.sbomify.com/CVE-2020-15230/): Arbitrary file read un Vapor (high 8.5)
- [CVE-2021-32742](https://insights.sbomify.com/CVE-2021-32742/): Untrusted data fed into `Data.init(base32Encoded:)` can result in exposing server memory and/or crash (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21328 and fix it if it is affected.

What it is: CVE-2021-21328 is a medium-severity denial of service vulnerability in vapor, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21328 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/vapor/vapor (SwiftURL): affected all versions; fixed in 4.40.1
- github.com/vapor/vapor (SwiftURL): affected all versions; fixed in 4.40.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21328/ (Markdown: https://insights.sbomify.com/CVE-2021-21328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21328
- OSV: https://osv.dev/vulnerability/CVE-2021-21328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21328/
Summaries are generated and may contain mistakes; the official description above is the record.
