# CVE-2021-21330: Open redirect vulnerability in aiohttp

> Attackers can redirect users to malicious sites via crafted links in aiohttp web servers using the normalize_path_middleware.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-44805, DEBIAN-CVE-2021-21330, DSA-4864-1, GHSA-v6wp-4m6f-gcjg, MGASA-2021-0161, PYSEC-2021-76, SUSE-RU-2022:3275-1, SUSE-SU-2021:1313-1, UBUNTU-CVE-2021-21330, USN-5386-1, openSUSE-SU-2024:13209-1

## What is CVE-2021-21330?

CVE-2021-21330 is a low-severity vulnerability in Debian Debian Linux, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. In aiohttp before version 3.7.4 there is an open redirect vulnerability. A maliciously crafted link to an aiohttp-based web-server could redirect the browser to a different website. It is caused by a bug in the `aiohttp.web_middlewares.normalize_path_middleware` middleware. This security problem has been fixed in 3.7.4. Upgrade your dependency using pip as follows "pip install aiohttp >= 3.7.4". If upgrading is not an option for you, a workaround can be to avoid using `aiohttp.web_middlewares.normalize_path_middleware` in your applications.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-21330?

3 open source packages ship an affected version, including aiohttp. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.7.4 |
| `aiohttp` | PyPI | All versions | 3.7.4 |
| `aiohttp` | PyPI | All versions | 3.7.4 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 3.4.4-3.6.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 3.6.0-150100.3.9.1 |
| `python-typing_extensions` | SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 3.10.0.0-150100.3.3.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 3.4.4-3.6.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 3.6.0-150100.3.9.1 |
| `python-typing_extensions` | SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 3.10.0.0-150100.3.3.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.6.0-150100.3.9.1 |
| `python-typing_extensions` | SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.10.0.0-150100.3.3.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.6.0-150100.3.9.1 |
| `python-typing_extensions` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 3.10.0.0-150400.3.2.1 |
| `python-aiohttp` | openSUSE:Leap 15.3 | All versions | 3.6.0-150100.3.9.1 |
| `python-aiohttp` | openSUSE:Leap 15.4 | All versions | 3.6.0-150100.3.9.1 |
| `python-typing_extensions` | openSUSE:Leap 15.4 | All versions | 3.10.0.0-150400.3.2.1 |
| `python-aiohttp` | openSUSE:Tumbleweed | All versions | 3.8.5-2.1 |

Products: Aiohttp Aiohttp, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2021-21330?

Upgrade aiohttp to 3.7.4 or later.

## Is CVE-2021-21330 being exploited?

There is no known exploitation of CVE-2021-21330 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21330 and fix it if it is affected.

What it is: CVE-2021-21330 is a low-severity vulnerability in Debian Debian Linux, published on 26 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21330 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.7.4
- aiohttp (PyPI): affected all versions; fixed in 3.7.4
- aiohttp (PyPI): affected all versions; fixed in 3.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21330/ (Markdown: https://insights.sbomify.com/CVE-2021-21330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21330
- OSV: https://osv.dev/vulnerability/CVE-2021-21330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21330/
Summaries are generated and may contain mistakes; the official description above is the record.
