# CVE-2021-21331: DataDog API Client contains a Local Information Disclosure Vulnerability

> Local attackers can read sensitive files downloaded by the DataDog Java API client due to insecure temporary file permissions on multi-user systems.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2cxf-6567-7pp6

## What is CVE-2021-21331?

CVE-2021-21331 is a low-severity vulnerability in datadog-api-client-java, published on 3 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Java client for the Datadog API before version 1.0.0-beta.9 has a local information disclosure of sensitive information downloaded via the API using the API Client. The Datadog API is executed on a unix-like system with multiple users. The API is used to download a file containing sensitive information. This sensitive information is exposed locally to other users. This vulnerability exists in the API Client for version 1 and 2. The method `prepareDownloadFilecreates` creates a temporary file with the permissions bits of `-rw-r--r--` on unix-like systems. On unix-like systems, the system temporary directory is shared between users. As such, the contents of the file downloaded via the `downloadFileFromResponse` method will be visible to all other users on the local system. Analysis of the finding determined that the affected code was unused, meaning that the exploitation likelihood is low. The unused code has been removed, effectively mitigating this issue. This issue has been patched in version 1.0.0-beta.9. As a workaround one may specify `java.io.tmpdir` when starting the JVM with the flag `-Djava.io.tmpdir`, specifying a path to a directory with `drw-------` permissions owned by `dd-agent`.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions), CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2021-21331?

2 open source packages ship an affected version, including com.datadoghq:datadog-api-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.datadoghq:datadog-api-client` | Maven | From 1.0.0-beta.6 | 1.0.0-beta.9 |
| `com.datadoghq:datadog-api-client` | Maven | From 1.0.0-beta.6 | 1.0.0-beta.9 |

Products: Datadoghq Datadog-Api-Client-Java.

## How do I fix CVE-2021-21331?

Upgrade com.datadoghq:datadog-api-client to 1.0.0-beta.9 or later.

## Is CVE-2021-21331 being exploited?

There is no known exploitation of CVE-2021-21331 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21331 and fix it if it is affected.

What it is: CVE-2021-21331 is a low-severity vulnerability in datadog-api-client-java, published on 3 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21331 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.datadoghq:datadog-api-client (Maven): affected from 1.0.0-beta.6; fixed in 1.0.0-beta.9
- com.datadoghq:datadog-api-client (Maven): affected from 1.0.0-beta.6; fixed in 1.0.0-beta.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21331/ (Markdown: https://insights.sbomify.com/CVE-2021-21331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21331
- OSV: https://osv.dev/vulnerability/CVE-2021-21331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21331/
Summaries are generated and may contain mistakes; the official description above is the record.
