# CVE-2021-21332: Cross-site scripting (XSS) vulnerability in the password reset endpoint

> An XSS vulnerability in the password reset endpoint allows attackers to steal cookies and browser data, potentially leading to account takeover.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-246w-56m2-5899, PYSEC-2021-133, UBUNTU-CVE-2021-21332

## What is CVE-2021-21332?

CVE-2021-21332 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.27.0, the password reset endpoint served via Synapse was vulnerable to cross-site scripting (XSS) attacks. The impact depends on the configuration of the domain that Synapse is deployed on, but may allow access to cookies and other browser data, CSRF vulnerabilities, and access to other resources served on the same domain or parent domains. This is fixed in version 1.27.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21332?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.27.0 |
| `matrix-synapse` | PyPI | All versions | 1.27.0 |
| `matrix-synapse` | PyPI | All versions | 1.27.0 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-21332?

Upgrade matrix-synapse to 1.27.0 or later.

## Is CVE-2021-21332 being exploited?

There is no known exploitation of CVE-2021-21332 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21332 and fix it if it is affected.

What it is: CVE-2021-21332 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 26 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21332 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.27.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.27.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21332/ (Markdown: https://insights.sbomify.com/CVE-2021-21332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21332
- OSV: https://osv.dev/vulnerability/CVE-2021-21332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21332/
Summaries are generated and may contain mistakes; the official description above is the record.
