CVE-2021-21334 environment variable leak
Attackers can read sensitive environment variables from other containers sharing the same image due to a race condition in containerd's CRI implementation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21334?
CVE-2021-21334 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.
Weakness: CWE-668
Which versions are affected by CVE-2021-21334?
4 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd Go | All versions | 1.3.10 |
github.com/containerd/containerd Go | All versions | 1.3.10 |
github.com/containerd/containerd Go | From 1.4.0 | 1.4.4 |
github.com/containerd/containerd Go | From 1.4.0 | 1.4.4 |
Products include Fedoraproject Fedora, Linuxfoundation Containerd.
How do I fix CVE-2021-21334?
Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.3.10 or 1.4.4.
Is CVE-2021-21334 being exploited?
There is no known exploitation of CVE-2021-21334 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-44910, AZL-81209, CLEANSTART-2025-BS91981, DEBIAN-CVE-2021-21334, GHSA-6g2q-w5j3-fwh4, MGASA-2021-0248 and 2 more.