{"answers":{"affected":"4 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-21334 in the wild and no public exploit code.","fix":"Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.3.10 or 1.4.4.","what":"CVE-2021-21334 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21334 and fix it if it is affected.\n\nWhat it is: CVE-2021-21334 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21334 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.10\n- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.10\n- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.4\n- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21334/ (Markdown: https://insights.sbomify.com/CVE-2021-21334/index.md)","id":"CVE-2021-21334","markdown":"https://insights.sbomify.com/CVE-2021-21334/index.md","name":"CVE-2021-21334","record":{"aliases":["AZL-44910","AZL-81209","CLEANSTART-2025-BS91981","DEBIAN-CVE-2021-21334","GHSA-6g2q-w5j3-fwh4","MGASA-2021-0248","UBUNTU-CVE-2021-21334","USN-4881-1"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"container runtime","requires_auth":"low_privilege","summary":"Attackers can read sensitive environment variables from other containers sharing the same image due to a race condition in containerd's CRI implementation.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"containerd","vendor":"linuxfoundation"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"}],"description":"In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"environment variable leak","id":"CVE-2021-21334","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"information_disclosure","year":"2021"},"n_packages":4,"n_references":8,"next":{"headline":"Basic Authentication can be bypassed using a malformed username","id":"CVE-2021-21335"},"packages":[{"ecosystem":"Go","fixed":["1.3.10"],"introduced":["0"],"last_affected":[],"package":"github.com/containerd/containerd","purl":null,"source":"GHSA-6g2q-w5j3-fwh4"},{"ecosystem":"Go","fixed":["1.3.10"],"introduced":["0"],"last_affected":[],"package":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","source":"GHSA-6g2q-w5j3-fwh4"},{"ecosystem":"Go","fixed":["1.4.4"],"introduced":["1.4.0"],"last_affected":[],"package":"github.com/containerd/containerd","purl":null,"source":"GHSA-6g2q-w5j3-fwh4"},{"ecosystem":"Go","fixed":["1.4.4"],"introduced":["1.4.0"],"last_affected":[],"package":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","source":"GHSA-6g2q-w5j3-fwh4"}],"prev":{"headline":"HTML injection in email and account expiry notifications","id":"CVE-2021-21333"},"products":["containerd"],"published":"2021-03-10","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["containerd"]},"summary":"Attackers can read sensitive environment variables from other containers sharing the same image due to a race condition in containerd's CRI implementation.","url":"https://insights.sbomify.com/CVE-2021-21334/"}