# CVE-2021-21334: environment variable leak

> Attackers can read sensitive environment variables from other containers sharing the same image due to a race condition in containerd's CRI implementation.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-44910, AZL-81209, CLEANSTART-2025-BS91981, DEBIAN-CVE-2021-21334, GHSA-6g2q-w5j3-fwh4, MGASA-2021-0248, UBUNTU-CVE-2021-21334, USN-4881-1

## What is CVE-2021-21334?

CVE-2021-21334 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2021-21334?

4 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.3.10 |
| `github.com/containerd/containerd` | Go | All versions | 1.3.10 |
| `github.com/containerd/containerd` | Go | From 1.4.0 | 1.4.4 |
| `github.com/containerd/containerd` | Go | From 1.4.0 | 1.4.4 |

Products: Fedoraproject Fedora, Linuxfoundation Containerd.

## How do I fix CVE-2021-21334?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.3.10 or 1.4.4.

## Is CVE-2021-21334 being exploited?

There is no known exploitation of CVE-2021-21334 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21334 and fix it if it is affected.

What it is: CVE-2021-21334 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21334 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.10
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.10
- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.4
- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21334/ (Markdown: https://insights.sbomify.com/CVE-2021-21334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21334
- OSV: https://osv.dev/vulnerability/CVE-2021-21334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21334/
Summaries are generated and may contain mistakes; the official description above is the record.
