{"answers":{"affected":"3 open source packages ship an affected version, including products-pluggableauthservice and Products.PluggableAuthService. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-21336 in the wild and no public exploit code.","fix":"Upgrade products-pluggableauthservice to 2.6.0 or later.","what":"CVE-2021-21336 is a medium-severity vulnerability in Plone Plone, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21336 and fix it if it is affected.\n\nWhat it is: CVE-2021-21336 is a medium-severity vulnerability in Plone Plone, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21336 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.0\n- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.0\n- Products.PluggableAuthService (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21336/ (Markdown: https://insights.sbomify.com/CVE-2021-21336/index.md)","id":"CVE-2021-21336","markdown":"https://insights.sbomify.com/CVE-2021-21336/index.md","name":"CVE-2021-21336","record":{"aliases":["GHSA-p75f-g7gx-2r7p","PYSEC-2021-44"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Zope authentication library","requires_auth":"low_privilege","summary":"An attacker can list role names in the ZODB Role Manager plugin if enabled, exposing sensitive configuration details.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"plone","vendor":"plone"},{"product":"products.pluggableauthservice","vendor":"zope"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install \"Products.PluggableAuthService\u003e=2.6.0\"`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager","id":"CVE-2021-21336","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"plone:plone","products":["plone:plone"],"type":"information_disclosure","year":"2021"},"n_packages":3,"n_references":5,"next":{"headline":"URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService","id":"CVE-2021-21337"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"Products.PluggableAuthService","purl":null,"source":"GHSA-p75f-g7gx-2r7p"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","source":"GHSA-p75f-g7gx-2r7p"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","source":"PYSEC-2021-44"}],"prev":{"headline":"Basic Authentication can be bypassed using a malformed username","id":"CVE-2021-21335"},"products":["Products.PluggableAuthService"],"published":"2021-03-08","related":[{"cvss_score":9.9,"headline":"Incorrect Permission Assignment for Critical Resource in Plone","id":"CVE-2021-33509","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2020-35190","kev_date_added":null,"published":"2020-12-17"},{"cvss_score":9.8,"headline":"Plone Unauthenticated Write Vulnerability","id":"CVE-2020-7941","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":9.3,"headline":"Zope Command Execution Vulnerability","id":"CVE-2011-3587","kev_date_added":null,"published":"2011-10-10"},{"cvss_score":8.8,"headline":"Server-Side Request Forgery in Plone CMS","id":"CVE-2021-33926","kev_date_added":null,"published":"2023-02-17"},{"cvss_score":8.8,"headline":"Improper Restriction of XML External Entity Reference in Plone","id":"CVE-2020-28734","kev_date_added":null,"published":"2020-12-30"},{"cvss_score":8.8,"headline":"SSRF attacks via tracebacks in Plone","id":"CVE-2020-28735","kev_date_added":null,"published":"2020-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["zopefoundation"]},"summary":"An attacker can list role names in the ZODB Role Manager plugin if enabled, exposing sensitive configuration details.","url":"https://insights.sbomify.com/CVE-2021-21336/"}