# CVE-2021-21336: Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager

> An attacker can list role names in the ZODB Role Manager plugin if enabled, exposing sensitive configuration details.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p75f-g7gx-2r7p, PYSEC-2021-44

## What is CVE-2021-21336?

CVE-2021-21336 is a medium-severity vulnerability in Plone Plone, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-21336?

3 open source packages ship an affected version, including products-pluggableauthservice and Products.PluggableAuthService. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `products-pluggableauthservice` | PyPI | All versions | 2.6.0 |
| `products-pluggableauthservice` | PyPI | All versions | 2.6.0 |
| `Products.PluggableAuthService` | PyPI | All versions | 2.6.0 |

Products: Plone Plone, Zope Products.pluggableauthservice.

## How do I fix CVE-2021-21336?

Upgrade products-pluggableauthservice to 2.6.0 or later.

## Is CVE-2021-21336 being exploited?

There is no known exploitation of CVE-2021-21336 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21336 and fix it if it is affected.

What it is: CVE-2021-21336 is a medium-severity vulnerability in Plone Plone, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21336 in the wild and no public exploit code.

Affected packages and fixed versions:
- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.0
- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.0
- Products.PluggableAuthService (PyPI): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21336/ (Markdown: https://insights.sbomify.com/CVE-2021-21336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21336
- OSV: https://osv.dev/vulnerability/CVE-2021-21336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21336/
Summaries are generated and may contain mistakes; the official description above is the record.
