{"answers":{"affected":"3 open source packages ship an affected version, including Products.PluggableAuthService and products-pluggableauthservice. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21337 in the wild and no public exploit code.","fix":"Upgrade Products.PluggableAuthService to 2.6.1 or later.","what":"CVE-2021-21337 is a medium-severity vulnerability in zopefoundation Products.PluggableAuthService, published on 8 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21337 and fix it if it is affected.\n\nWhat it is: CVE-2021-21337 is a medium-severity vulnerability in zopefoundation Products.PluggableAuthService, published on 8 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21337 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Products.PluggableAuthService (PyPI): affected all versions; fixed in 2.6.1\n- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.1\n- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21337/ (Markdown: https://insights.sbomify.com/CVE-2021-21337/index.md)","id":"CVE-2021-21337","markdown":"https://insights.sbomify.com/CVE-2021-21337/index.md","name":"CVE-2021-21337","record":{"aliases":["GHSA-p44j-xrqg-4xrr","PYSEC-2021-45"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope authentication library","requires_auth":"low_privilege","summary":"An attacker can craft a malicious link to the login form to redirect users to an untrusted external website.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"products.pluggableauthservice","vendor":"zope"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install \"Products.PluggableAuthService\u003e=2.6.1\".","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2021-06-02","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-06-02","kind":"exploitdb","ref":"49930","stars":null,"title":"Products.PluggableAuthService 2.6.0 - Open Redirect"}],"tier":"poc_unverified"},"has_fix":true,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService","id":"CVE-2021-21337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"open_redirect","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"Open Redirection in Login Handling","id":"CVE-2021-21338"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"Products.PluggableAuthService","purl":null,"source":"GHSA-p44j-xrqg-4xrr"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","source":"GHSA-p44j-xrqg-4xrr"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","source":"PYSEC-2021-45"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager","id":"CVE-2021-21336"},"products":["Products.PluggableAuthService"],"published":"2021-03-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["zopefoundation"]},"summary":"An attacker can craft a malicious link to the login form to redirect users to an untrusted external website.","url":"https://insights.sbomify.com/CVE-2021-21337/"}