CVE-2021-21340 Cross-Site Scripting in Content Preview
Authenticated backend users can trigger cross-site scripting via database description fields during content preview in TYPO3.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21340?
CVE-2021-21340 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 23 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 10.4.14, 11.1.1 it has been discovered that database fields used as _descriptionColumn_ are vulnerable to cross-site scripting when their content gets previewed. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 10.4.14, 11.1.1 .
Weakness: CWE-79
Which versions are affected by CVE-2021-21340?
13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-backend. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 10.0.0 | 10.4.14 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3/cms Packagist | From 11.0.0 | 11.1.1 |
typo3 Bitnami | From 10.0.0 | 10.4.14, 11.1.1 |
typo3/cms-backend Packagist | From 10.0.0 | 10.4.14 |
7 more packages
typo3/cms-backend Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-backend Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-backend Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.14 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
typo3/cms-core Packagist | From 11.0.0 | 11.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2021-21340?
Upgrade typo3/cms to a fixed version for your release line: 10.4.14 or 11.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-21340 being exploited?
There is no known exploitation of CVE-2021-21340 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2021-21340, GHSA-fjh3-g8gq-9q92.