CVE-2021-21344 XStream is vulnerable to an Arbitrary Code Execution attack
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-21344?
CVE-2021-21344 is a medium-severity vulnerability in Apache Activemq, published on 22 Mar 2021.
Official description
XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is a vulnerability which may allow a remote attacker to load and execute arbitrary code from a remote host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.
Which versions are affected by CVE-2021-21344?
3 open source packages ship an affected version, including activemq and com.thoughtworks.xstream:xstream. It affects 16 products.
| Package | Affected | Fixed in |
|---|---|---|
activemq Bitnami | All versions to 5.16.0 | 5.15.14 |
com.thoughtworks.xstream:xstream Maven | All versions | 1.4.16 |
com.thoughtworks.xstream:xstream Maven | All versions | 1.4.16 |
Products include Apache Activemq, Apache Jmeter, Debian Debian Linux, Fedoraproject Fedora, Netapp Oncommand Insight, Oracle Banking Enterprise Default Management and 10 more.
How do I fix CVE-2021-21344?
Upgrade activemq to 5.15.14 or later.
Is CVE-2021-21344 being exploited?
There is no known exploitation of CVE-2021-21344 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2021-21344, DEBIAN-CVE-2021-21344, GHSA-59jw-jqf4-3wq3, UBUNTU-CVE-2021-21344.